スキップしてメイン コンテンツに移動

nspluginwrapper

nspluginwrapper

x86_64なfirefoxでi386のプラグインを使うには。



もちろん、i386のプラグイン実行用にi386環境は必要になるけど、i386のfirefox一式入れるよりはよっぽどヨイ。



AdobeReader & flash-pluginに引っ張られた人たち。(そのもの含む)


$ yum list installed | grep \\.i386
atk.i386                                 1.18.0-1.fc7           installed
cairo.i386                               1.4.10-1.fc7           installed
cups-libs.i386                           1:1.2.12-5.fc7         installed
expat.i386                               1.95.8-9               installed
flash-plugin.i386                        9.0.48.0-release       installed
fontconfig.i386                          2.4.2-3.fc7            installed
freetype.i386                            2.3.4-3.fc7            installed
glib2.i386                               2.12.13-1.fc7          installed
glibc.i386                               2.6-4                  installed
gnutls.i386                              1.6.3-2.fc7            installed
gtk2.i386                                2.10.14-3.fc7          installed
gtk2-devel.i386                          2.10.14-3.fc7          installed
libICE.i386                              1.0.3-2.1.fc7          installed
libSM.i386                               1.0.2-1                installed
libX11.i386                              1.0.3-8.fc7            installed
libXau.i386                              1.0.3-1.fc7            installed
libXcursor.i386                          1.1.8-1                installed
libXdmcp.i386                            1.0.2-2.fc7            installed
libXext.i386                             1.0.1-2.1              installed
libXfixes.i386                           4.0.3-1                installed
libXft.i386                              2.1.12-1.fc7           installed
libXi.i386                               1.1.1-1.fc7            installed
libXinerama.i386                         1.0.2-1.fc7            installed
libXrandr.i386                           1.2.0-3.fc7            installed
libXrender.i386                          0.9.2-1.fc7            installed
libXt.i386                               1.0.4-1.fc7            installed
libXxf86vm.i386                          1.0.1-3.1              installed
libdrm.i386                              2.3.0-5.fc7            installed
libgcc.i386                              4.1.2-12               installed
libgcrypt.i386                           1.2.4-1                installed
libgpg-error.i386                        1.4-2                  installed
libjpeg.i386                             6b-38.fc7              installed
libpng.i386                              2:1.2.22-1.fc7         installed
libselinux.i386                          2.0.14-9.fc7           installed
libsepol.i386                            2.0.3-1.fc7            installed
libstdc++.i386                           4.1.2-27.fc7           installed
libthai.i386                             0.1.7-5.fc7            installed
libtiff.i386                             3.8.2-8.fc7            installed
mesa-libGL.i386                          6.5.2-13.fc7           installed
mesa-libGLU.i386                         6.5.2-13.fc7           installed
pango.i386                               1.16.4-2.fc7           installed
zlib.i386                                1.2.3-10.fc7           installed


さらに、firefox.i386が引っ張ろうとする人たち。


$ sudo yum install firefox.i386=============================================================================
Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
firefox                 i386       2.0.0.8-1.fc7    updates            21 M
Installing for dependencies:
GConf2                  i386       2.18.0.1-2.fc7   fedora            1.6 M
ORBit2                  i386       2.14.7-3.fc7     fedora            256 k
alsa-lib                i386       1.0.14-3.fc7     updates           409 k
audiofile               i386       1:0.2.6-6.fc7    fedora            107 k
audit-libs              i386       1.5.6-2.fc7      updates            64 k
avahi                   i386       0.6.17-1.fc7     fedora            252 k
avahi-glib              i386       0.6.17-1.fc7     fedora             14 k
bzip2-libs              i386       1.0.4-10.fc7     fedora             37 k
cyrus-sasl-lib          i386       2.1.22-6         fedora            1.1 M
dbus                    i386       1.0.2-6.fc7      updates           467 k
dbus-glib               i386       0.73-3.fc7       updates           159 k
device-mapper-libs      i386       1.02.17-7.fc7    fedora             42 k
e2fsprogs-libs          i386       1.40.2-2.fc7     updates           135 k
esound-libs             i386       1:0.2.38-2.fc7   updates            30 k
gamin                   i386       0.1.8-5.fc7      fedora            120 k
gnome-keyring           i386       0.8-1.fc7        fedora            179 k
gnome-vfs2              i386       2.18.1-4.fc7     fedora            1.3 M
hal-libs                i386       0.5.9-8.fc7      fedora             55 k
keyutils-libs           i386       1.2-2.fc6        fedora             18 k
krb5-libs               i386       1.6.1-4.fc7      updates           647 k
libIDL                  i386       0.8.8-1.fc7      fedora             87 k
libacl                  i386       2.2.39-3.1.fc7   fedora             19 k
libart_lgpl             i386       2.3.19-2.fc7     fedora             77 k
libattr                 i386       2.4.32-2.fc7     fedora             12 k
libbonobo               i386       2.18.0-3.fc7     fedora            511 k
libbonoboui             i386       2.18.0-1.fc7     fedora            396 k
libcap                  i386       1.10-29          fedora             24 k
libdaemon               i386       0.11-2.fc7       updates            25 k
libglade2               i386       2.6.0-3.fc7      fedora             96 k
libgnome                i386       2.18.0-4.fc7     fedora            971 k
libgnomecanvas          i386       2.14.0-5.fc7     fedora            222 k
libgnomeui              i386       2.18.1-2.fc7     fedora            1.0 M
libxml2                 i386       2.6.29-1.fc7     updates           815 k
nspr                    i386       4.6.7-0.7.1.fc7  updates           119 k
nss                     i386       3.11.7-0.7.2.fc7  updates           810 k
openldap                i386       2.3.34-3.fc7     updates           290 k
openssl                 i386       0.9.8b-15.fc7    updates           1.4 M
popt                    i386       1.10.2.2-2.fc7   updates            70 k


Transaction Summary
=============================================================================
Install     39 Package(s)
Update       0 Package(s)
Remove       0 Package(s)


Total download size: 34 M

コメント

このブログの人気の投稿

BCM交換(失敗編)

1 20S左側オートスライド+インテリキー用から
20G,RX左側オートスライド+インテリキー用にBCMを交換する。
バッテリマイナス外すのも含めてものの数分。
楽勝ですな。

2 作動チェック。
Hiビーム動作する。うんうん。

3 リモコン、ドア等も正常、オートライトも動作する。
センサーついてないから常時消灯->常時点灯にかわっただけだけど。

4 いいかんじなので車庫にもどそうとしてイグニッションノブ捻ると、セルが回らないことが発覚。

5 ドキドキしながら旧BCMに戻す。
エンジン始動。ふぅ。

6 インテリキー仕様の始動にBCM関係なさそうなんだけどなぁ。ノブも回らないではなくてstart位置まで回ってセルが回らないという状態だし。うーむ。
あ、イモビの赤インジケータ点いてないね...

7 インテリキーはコントローラ別体なのでちゃんと動作していたけれども、イモビがBCM交換するとダメらしい。
木曜日にディーラにイモビの設定お願いする。
問題は新BCMだと自走できないのでディーラにBCM交換も依頼しなければならないあたり。

8 で、すんなり再設定できて動けばいいんだけど...

今日の都電